由安装yarn引发的血案

今天在mac上搞vuepress的时候,用npm安装的出现各种问题(和webpack3.x出现的问题),所以需要安装yarn。

我用brew命令安装的时候,报错,没权限,提示用下面语句设置权限:

sudo chown -R $(whoami) /usr/local

输入之后提示:

chown: /usr/local: Operation not permitted

我也不知道改怎么搞了,有不能用sudo,又不能设置权限…后来搜了一下,是brew的问题,解决方法:

先卸载已安装的homebrew

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/uninstall)"

提示让你删除(自动以操作)的文件不用管就行了,都是正常系统文件。然后重新安装:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

然后下面的通过命令就可以正常安装yarn了

brew install yarn

发表评论